The game runs very slowly for me. What can I do to fix this?

  1. Make sure the power setting for your system is set to “High performance.”
  2. Make sure your system is using its best available graphics solution. If you know your system has only one graphics solution, you can skip this. Otherwise, you will have to manually go into your graphics control panel. For NVIDIA users, right click on your desktop and select “NVIDIA Control Panel” from the window. Select “Manage 3D settings” in the left panel. Under the “Global Settings” tab, look for the “Preferred graphics processor:” label. Click the drop down box to see the graphics solutions your system has installed. If you have more than one option listed, select “High-performance NVIDIA processor” then click “Apply” at the bottom right of the control panel.
  3. Lower your Xulu graphics settings in the preferences control. To open the preferences dialog, press the ‘Esc’ key on your keyboard and select “Preferences” from the resulting dialog. In the preferences dialog, select “Basic Settings”, then set the “Graphics Quality” to “Very Low.” If this improves your performance, you will have to play with the graphics settings to find a balance between quality and performance (note that shadows and larger screen resolutions are particularly costly).

If this does not improve your performance, e-mail for further assistance.

Comments Are Closed